Go Back   EQEmulator Home > EQEmulator Forums > Development > Development::Development

Development::Development Forum for development topics and for those interested in EQEMu development. (Not a support forum)

Reply
 
Thread Tools Display Modes
  #1  
Old 10-22-2023, 04:14 PM
HaraminWinterstorm
Fire Beetle
 
Join Date: Sep 2012
Location: Omaha
Posts: 1
Default Need help Blender Animating

Previously posted this in the wrong forum section.

Ok, so I haven't posted anything on a forum since like 2002, I generally try to figure it out for myself.
I am a full stack developer so I figured it wouldn't be too much until I encountered blender / animating...

Scope:
I'm creating a custom zone that is the hub of where everyone starts.
That zone will have a hub for every city that will port them to their respective starting cities.
Qeynos - Humans
Halas Hub - Halas.
So on so fourth.
I've created my own items/armor and currency and that is all implemented and great...
I've implemented my own music
My world exploded when it got to erudin and the teleport pads.

I'm using Blender and the eqemulator docs is either a heavy learning curve, talks in nuances (expecting you to already have used the program), or isn't finished.

I used ZoneConverter to grab the shapes, was doing everything before by hand...

I used the debug tool from eqzi-manager to try and set the e_textureDiffuse.
When right clicking and adding a property, it says it goes through and I save it. Then coming back to it, any other properties are gone.

I use EQZip to rip the assets from erudin object that's where I gathered all the textures.

I tried making a test_c.txt like it was saying in the docs with
3
500
Material09.001.png
Material11.001.png
Material12.001.png

That didn't do anything, nor do I think I completely understand that?

I tried spawning doors and objects, but none contained this specific teleporter, but I'd like to figure out the animation outside of the objects and doors to be able to have an overall customizable designs

I'm not here to bash the docs just venting my frustrations on my lack of understanding. But this has been driving me crazy.

If anyone could help I would be so grateful, I'd also like to animate fire, and make water in the zone also... (Note: Made water in blender my first days, the animation didn't carry over.)

Here's a rendition of what I've been working on for any clarity.
(3minutes 20 seconds) in is where my zone comes into play.

https://youtu.be/R0dIZCQms9U?si=ydeS8_1nvSV18LDQ

Please help lol.
Thanks!

Included images










https://drive.google.com/file/d/1Ray...usp=share_link

https://drive.google.com/file/d/1N82...ew?usp=sharing

https://drive.google.com/file/d/1099...ew?usp=sharing

https://drive.google.com/file/d/12V6...ew?usp=sharing

https://drive.google.com/file/d/15L3...ew?usp=sharing
Reply With Quote
  #2  
Old 10-26-2023, 10:51 PM
DeadZergling
Fire Beetle
 
Join Date: Jun 2018
Location: Washington State
Posts: 4
Default Regarding the animated textures

Hey there HaraminWinterstorm, didn't see anyone responding to this so figured I should at least point out some issues your animated textures might be having. I assume you are using eqgzi or eqgzi-manager to utilize the text file, the text file won't do anything for you otherwise. Also, the shader name in blender doesn't matter so much, the base image texture it points towards is what correlates to the text file.

For example, I have a simple 2 texture animated texture, the shader is named TreasureRoom, the base image texture is treasureroom1.dds, and I use a txt file of treasureroom1.txt. I haven't really had much luck with PNG, so I usually just use DDS for animations. The contents of my txt are as follows:

2
1500
treasureroom1.dds
treasureroom2.dds

Saying you have 2 images to use, a delay of 1500 milliseconds between changes, and the 2 file names to use that should be in the folder with your blend. I noticed you have some periods in the image names in your example, I don't know if they make an impact or not, but it would also be something I would change to rule that out as a possible issue.
Reply With Quote
Reply

Tags
animation, blender

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

   

All times are GMT -4. The time now is 04:03 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3